build.gradle 877 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. group 'fr.pointcheval.native_crypto'
  2. version '1.0-SNAPSHOT'
  3. buildscript {
  4. ext.kotlin_version = '1.3.50'
  5. repositories {
  6. google()
  7. jcenter()
  8. }
  9. dependencies {
  10. classpath 'com.android.tools.build:gradle:3.5.0'
  11. classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
  12. }
  13. }
  14. rootProject.allprojects {
  15. repositories {
  16. google()
  17. jcenter()
  18. }
  19. }
  20. apply plugin: 'com.android.library'
  21. apply plugin: 'kotlin-android'
  22. android {
  23. compileSdkVersion 28
  24. sourceSets {
  25. main.java.srcDirs += 'src/main/kotlin'
  26. }
  27. defaultConfig {
  28. minSdkVersion 16
  29. testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner"
  30. }
  31. lintOptions {
  32. disable 'InvalidPackage'
  33. }
  34. }
  35. dependencies {
  36. implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"
  37. }